SQLiteManager 1.2.1 (Support PHP 5.3)

Je travaille actuellement sur une nouvelle version de EWS (Easy Web Server) et en mettant à jour ses composants,
je me suis rendu compte que PHP 5.3 apportait énormément de changements, car c'est une version plus proche de PHP 6.0 que de PHP 5.0

J'ai contribué il y a quelques années au projet SQLiteManager (Theme, amélioration du code) et j'ai donc passé quelques heures afin de le mettre à jour...

Voici donc en pièce jointe la préversion 1.2.1, qui ne contient pas de nouveautés, mais qui supporte aussi bien PHP 5.3 que les versions précédentes...

EDIT : Une nouvelle version 1.2.3 est disponible sur SF.net (qui prend en compte mes modificiations) avec de nouveaux correctifs...

Fichier attachéTailleDownloadsLast Download
SQLiteManager.1.2.1.(php53).rar929.73 Ko2235il y a 5 jours 16h

Commentaires

Options d'affichage des commentaires

Sélectionnez la méthode d'affichage des commentaires que vous préférez, puis cliquez sur "Sauvegarder les paramètres" pour activer vos changements.

I got an error, while editing

I got an error, while editing a row:

Warning: preg_replace() expects at least 3 parameters, 2 given in \SQLiteManager\include\SQLiteTableProperties.class.php on line 638

replace preg_replace() by

replace preg_replace() by preg_match

its ok in the v1.2.4

if(preg_match('#CHAR|TEXT|LOB|DATE#i', $tempType)) $funcVal = quotes($value);
else $funcVal = $value;